Your site is running on Wordpress 3.1.2. Travel Blogger Theme requires at least Wordpress 3.2. Please consider upgrading WordPress, it's safer, faster and carries more features.